PHP 3001 and up